follow us on google+ follow us feedburner

FORUM

Alias Not Working (Sometimes)



Posted by: wlitwa
April 01, 2014 09:34AM
Took me a while, but I finally got aliases to work by switching EasyPHP from running Apache and MySQL as services to not. In other words, I can't get aliases to work AT ALL if they're running as services OR if they're not, but ONLY if I switch between both.

I've had two aliases running just fine. I've added three more and all of them return a "404 Object Not Found." I've restarted Apache, restarted EasyPHP, checked folder permissions, run additional test-aliases on different folders, but nothing.

Running Windows 8.1.

- The config in apache_alias.conf is identical from one alias to the next except the folder name (auto-added via Admin panel).
- The working and non-working folders are in the same parent directory.
- All folders have the same permissions.
- I've restarted Apache.
- I've stopped Apache, waited a bit, and started it.
- I've restarted EasyPHP.
- I've tried accessing from both 127.0.0.1 and localhost.
- I've tried with and without index files.

The ONLY WAY I can get aliases to work AT ALL is if I configure EasyPHP to run Apache and MySQL as services, wait, quit EasyPHP, restart EasyPHP, reconfigure to NOT run as services, then start the servers. And that is THE ONLY way I can figure out how to make it work.

Bizarre.
Options: ReplyQuote


Your Name: 
Your Email: 
Subject: 
Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.