follow us on google+ follow us feedburner

FORUM
Please use the search function and/or read the FAQ first.

When php starts it shows a message [ "php start" - OK] we have to validate twice...



Posted by: Trebly
February 13, 2013 10:45AM
Hi,

When I install 12.1 I was surprised to have to click OK twice when php starts, I had never seens this before.

The problem, you imagine is that it is impossible to get an automatic restart.

How to put out these meessages ?, which parameter ?, where ?.

It is sure that the interface don't reports a status for php (only Apache and Mysql) but these message are a real annoyance.

Thank to tell me how to avoid this, in fact, lock of auto start capability.

Best regards

Trebly



Edited 1 time(s). Last edit at 02/13/2013 01:30PM by Trebly.
Options: ReplyQuote
Posted by: Russell
February 13, 2013 07:10PM
Right click on your EasyPHP icon in the taskbar (bottom right with clock).

From the popup menu, select Configuration > EasyPHP

In the resulting window, uncheck "Start on session startup." then click OK. That should stop it auto starting.
Options: ReplyQuote
Posted by: Trebly
February 14, 2013 01:56AM
Hi,

Sorry but it is not the problem.

It is sure that if I don't start Easyphp then I do not start Apache I will not get the message because nothing has been started.

The question is : how not to get the message "when" Apache starts and launch php interpreter which generates the message "Php start" with a validation "OK" (twice).

This unallows in anycase an automatic start.

May be I was not clear because, I try to be short, when apache is lauched by manually Easyphp run, start at session start, or installed as service the same message(s) appears too.

So apache can never restart automatically after a failure or be started with the session without manual validation (twice).
Options: ReplyQuote
Posted by: Russell
February 14, 2013 07:38PM
Oh, I thought "Thank to tell me how to avoid this, in fact, lock of auto start capability." meant you wanted to stop EasyPHP from starting automatically, sorry.

I think I understand the problem now, however can you just clarify that it happens as soon as EasyPHP starts and not when you are trying to load a page or use the CLI.

So is the message just "Php start" in a windows dialog (which one, info, warning, error?) Could you screen dump it for us?

Do you get any information in your Logs, EasyPHP or either of the Apache logs? Is there anything in the Windows Event Viewer when this happens?
Options: ReplyQuote
Posted by: faithy
February 15, 2013 08:27PM
IT drives me crazy pleeaase help me....plz
Options: ReplyQuote
Posted by: Trebly
February 18, 2013 03:01PM
Hi,

Quite a long time to solve this problem, but it is done :

1- I confirm that at startup I was getting geenrally twice a little message (standard windows for me) with only as windows title 'Php' and text 'startup :" then the button "OK" (sorry I have not made a screenshot for this, it seems so simple...)

2- After this Apache starts, but crashes often with same condition in restart

3- There was no error message, except in php log and apache (error.log not recent) :

< "PHP Warning: PHP Startup: in Unknown on line 0" >
Followed by what seems a normal startup : no error message

I rebuild my php.ini and found the problem :

*********************************************************************************
*ERROR made in "path" because I upgrade from 3.5.6. (get option from old php.ini* *using compare) without taking care sufficiently *
*********************************************************************************

Then when Php starts it don't find some (most) of dll of extensions and others but this error is not reported (we could imagine a check load of dummy dll, try immediately to get the handle and send an message). So the necessity of a message which need a manual action to go farther is absolute. If this happens after a file system error Php will not be able to do his job...

For history and be aware
________________________
These errors comes from the changes of the Easyphp directory structure and extensions locations :

The php.ini has in comment (in comment to help) which are generally simply uncommented with right values :

__________________________________
;;;;;;;;;;;;;;;;;;;;;;;;;
; Paths and Directories ;
;;;;;;;;;;;;;;;;;;;;;;;;;

; UNIX: "/path1:/path2"
;include_path = ".:/php/includes"
;
; Windows: "\path1;\path2"
;include_path = ".;${path}\php\includes"
;
; PHP's default setting for include_path is ".;/path/to/php/pear"
; [php.net]
_______________________________________

The "includes" nor "pear" subdir path doesn't exist anymore with 12.1

The extensions dir
_______________________________________

; Directory in which the loadable extensions (modules) reside.
; [php.net]
; extension_dir = "./"
; On windows:
extension_dir = "${path}\php\php546x121205142547\ext\"
________________________________________
is OK but must be changed if you use "php\php546x130109181658"

In another way the xdebug*.dll have been migrating :

Till : 5.3.2 : the directory was : easyphp/php/ext/
Till : 5.3.6 : : easyphp/xdebug/
Since 12.1 : : easyphp/php/<php version>/

My Conclusion :
_______________

There are many reasons to change the directory structure and it is difficult when there are samples in comments to upgrade all of them.
So not to have very hard difficulties it is necessary, in my opinion, to upgrade Apache or Php version, as you will have to merge the ini files with your ancient ones (use of extensions, various specialized parameters, any case you don't start from nothing) the user need to check
1- all the dir of path
2- existency of all used modules or extensions in the right place
3- using php reference check all options existency (obsolete, future obsolete etc... )

You are not sure that an error will be reported clearly, the reason :
- generally detailed error are reported but enormous sometimes no : the reason is linked to the development process, the reported error have occured during development and test, but the most enormous as a path error, are situation that never occured else than in your installation

Best regards

Trebly
Options: ReplyQuote


Your Name: 
Your Email: 
Subject: 
Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.