follow us on google+ follow us feedburner

FORUM

Wordpress-What <dir> should the package and Easyphp be saved to?



January 17, 2013 06:16PM
System: Win7 64bit
Easyphp version 12.1
Wordpress version 3.4.1


I have tried many installation variations of where the Easyphp/wordpress modules should reside. Initially I could see the admin login and the theme front end but was unable to login. Then I read that I had to make changes to the wp_users profile through myphpadmin. Once I did this, Easyphp was unable to establish DB connection.

For Easyphp I have saved to the default C:\Program (x86)files directory and tried saving to the C:\users\Public. With this I have had limited success. In both cases, I am able to see the portable folder.

Where I am having problems is in correctly installing wordpress. I have edited the wp_config files and gone to the created database to modify ie. grant permissions to user. All to no avail.

I am at my wits end. My questions are

1) Where is the wordpress package supposed to reside? Is it in the Easyphp 'modules' or the 'www' sub directory.

2) Do I need to create a database user before downloading wordpress?

3) Should I move the Easyphp to the root of my machine's C:\ to get the best results from wordpress?

4) What am I missing out after have configuring wp_config and wp_users?


Cheers.
Options: ReplyQuote
January 17, 2013 06:20PM
Is there a compatibility issue between the wordpress module and easyphp version I am using?
Options: ReplyQuote
Posted by: Russell
January 17, 2013 06:47PM
If you got to the wordpress admin login screen, sounds like you were almost there. You've probably just mistyped the password that you created in the wordpress setup webpage.

Just in case you are using the wrong password, at the admin screen you are using the user admin and the password you created when setting up wordpress - not the MySQL credentials you use to connect to the database with.

If you can get back to the stage where you have the wordpress admin login screen, I can help you modify your wordpress admin password using phpmyadmin if you've forgotten it:

In phpmyadmin, open up the wordpress database, select the wp_users table and click edit on the admin record. Find the user_pass field and in the function drop down box select MD5. Now type the new password into the field. At the bottom of the wp_user record, click on "Go" and your password will be changed. Now go log into the wordpress admin screen using your new password.

As for your questions:
1) In the modules folder.
2) Its good practice to use a different user other than root but not essential to make it work.
3) No.
4) Without seeing the wp_config file I can't say. I have no idea why you are modifying the wp_users other than to change the password as I have shown above.
Options: ReplyQuote
January 18, 2013 02:18AM
Russell thanks for your response.

The wp_admin login doesn't display anymore. When I click on the back office button on Easyphp admin page I get the following error displayed:

<---Error establishing a database connection
This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at localhost. This could mean your host's database server is down.

Are you sure you have the correct username and password?
Are you sure that you have typed the correct hostname?
Are you sure that the database server is running?
If you're unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress Support Forums.---->

I have done everything expected of me in the wp_config file and established that Mysql server is running.

My only hunch is that I might Easyphp it in the wrong directory. It is currently in C:\Users\Public rather than the default root of Program Files (x86).

I decided to mock about with the wp_users to modify username and password as the default root user profile in phpmyadmin couldn't get me in.

Still scratching my head.
Options: ReplyQuote
Posted by: Russell
January 18, 2013 01:44PM
Wordpress uses its own users and passwords, they are different to MySQL's user and passwords. Wordpress needs you to add a MySQL username and password to the wp_config.php file but other than that, you have to use Wordpress credentials for any operation in Wordpress.

The folder EasyPHP is stored in should not matter as long as you installed it into that folder rather than moving it using windows explorer. If the admin panel is working and you can use phpmyadmin to access the database then you definitely don't have an issue with the location of the files.

The problem you have looks to be the wrong credentials in the wp_config.php file. Just make sure the database is running though (open phpmyadmin or check the traffic light in the EasyPHP app).

In the wp_config.php you just need to focus on the following 4 lines.

define('DB_NAME', 'mysite');
define('DB_USER', 'root');
define('DB_PASSWORD', 'Password123');
define('DB_HOST', 'localhost');

Make sure your database name is setup (it probably won't be mysite like the example above) you can get this name from phpmyadmin.

Next use a MySQL username and password in the DB_USER and DB_PASSWORD fields. This is not stored in wp_users!

Also make sure the database is declared as being localhost as I believe the default config for MySQL shipped with EasyPHP is to only allow localhost connections.
Options: ReplyQuote


Your Name: 
Your Email: 
Subject: 
Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.