follow us on google+ follow us feedburner


Go to Topic: PreviousNext
Go to: Message ListNew TopicSearchLog InPrint View

Can't open phpmyadmin at /home/mysql/

Posted by: DanieleRota
December 26, 2012 12:12PM
Hi, I just installed the latest version (12.1) but I can't access to phpmyadmin
the error is 404 and the url is []

What can i do?
Options: ReplyQuote
Posted by: Russell
December 27, 2012 04:11PM
Check your httpd.conf file, line 58. If it has an IP address followed by a colon and a number then you'll have to use that in your browser to get to your admin screen. e.g. if it says then you need to type in to your browser to get to your easyphp site.
Options: ReplyQuote
Posted by: DanieleRota
December 28, 2012 09:50AM
My address is []
But the page is not found.
In home folder there isn't something called "mysql" (folder or file).
Is right?
Options: ReplyQuote
Posted by: Russell
December 28, 2012 02:53PM
Firstly, sorry I rushed reading your post and assumed a few things.

There shouldn't be a MySQL directory inside the home directory of a standard EasyPHP install. Phpmyadmin should have its own module and is accessed from the home screen by clicking on the open button associated with phpmyadmin under the modules list.

For instance, the URL for my install is

If you don't have a phpmyadmin module you can download it from the easyphp site (although I think it comes as standard but am not 100% sure)
Options: ReplyQuote
Posted by: DanieleRota
December 29, 2012 02:26PM
I have a phpmyadmin module like you, and i can access to phpmyadmin here

is right? with the old versions of easyphp I used this url

How can I access from this url?
Options: ReplyQuote
Posted by: Russell
December 29, 2012 08:37PM
I'm not an expert with apache configuration so there maybe better ways, however I think these are your options:

1. Just use it the way it already works (pressing open on the module via the home page)

2. make an alias entry in your httpd.conf file, I don't think this would allow for, you'd just have to put See the alias entries already in the httpd.conf file for how to do this (starting about line 340)

3. copy the phpmyadmin3522x121226143809 into the home directory and then rename it to mysql (simplest yet dirtiest way to do it)

4. use a .htaccess file and rewrite rules (You'd have to ask someone else for the exact rules as I don't know them)
Options: ReplyQuote
Posted by: DanieleRota
December 31, 2012 11:34AM
I follow your option, and now I see phpmyadmin but it doesn't work (don't create table)
I will back to and old version of easyphp.
Thank you for your help
Options: ReplyQuote
Posted by: Russell
December 31, 2012 05:44PM
If you are happy with the old version of easyphp then maybe its best to use that if it works for you.

I can try to help you fix the problem but I will need more information to determine what has gone wrong.

Happy new year.
Options: ReplyQuote
Posted by: DanieleRota
January 01, 2013 06:11PM
I tried to copy my old folder with database file (mysql->data) but I can't use those db (can't create table).

If I create a new db from modules (phpmyadmin3522x121231120242) phpmyadmin works well (for the moment). I will use phpmyadmin from modules :-D

You can access to phpmyadmin from ctrl+y with 12.1 version?
Options: ReplyQuote
Posted by: Russell
January 01, 2013 07:00PM
Have you had a look in the privileges section for the database that you can't create tables in? Does the phpmyadmin user (root if you haven't changed the config file) have permission to create? You can add/edit users in this screen.

Can you create a table using the MySQL command line tool against these imported databases? See [] for help on how to use this to connect to your database.

I have no clue what you mean by ctrl+y to access phpmyadmin, was that a feature of the older EasyPHP?
Options: ReplyQuote
Posted by: DanieleRota
January 02, 2013 03:38PM
I tried to create tables directly from phpmyadmin.
ctrl+y is an easyphp shortcut to open phpmyadmin panel
Options: ReplyQuote
Posted by: Russell
January 02, 2013 05:16PM
In phpmyadmin, instead of trying to create the table in your database, check the privileges tab to see if the root user can create tables. I'm assuming the data files are write enabled and you can add data to the tables already there in which case it must just be a permission problem with the user root @

If you can't see any issues then it might just be best to use the export tab to copy all the structure and data into a .sql file:

1. Open your database in phpmyadmin, go to the export tab and create a .sql file.
2. Next move your old database(s) from the data directory (using windows Explorer, you might have to stop MySQL)
3. Go back to phpmyadmin and create new databases with the same name
4. Finally import the .sql file you made in step 1 into the new database.

This should mean you have all your old structures and data but can now add new tables.

Guess they got rid of the ctrl + y shortcut.
Options: ReplyQuote

Go to: Message ListSearchLog In
Your Name: 
Your Email: 
Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.